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INTRODUCTION TO DIGITISING

Requirements
This exercise requires a PC with Windows 95/98 or Windows NT,  ArcView 3.0 or later, and a 
connected digitising table. The exercise is adapted for a Wacom A3 digitising tablet.

Objectives
This exercise will give an introduction to digitising

Task
To pass the exercise you have to create and hand in a digitised map of the bedrock over part of 
the map SGU Ser Af nr 102.

Introduction

Vector data comprise three types of data:
Points discrete locations (wells, cities, deposits, mines)
lines (arcs) one dimensional structures (wires, roads, faults)
Polygons two dimensional areas (blocks, fields, lakes)

Arcs have left and right hand side and thus can be part of a polygon, whereas lines lack left 
and right hand side and can not be part of a polygon.

Digitising is the process of converting vector features on a printed map into digital format. To
do that you must have a digitising table connected to your computer and trace the features 
you are interested in capturing. Digitising can be done for capturing original data, or for 
updating existing.

Prepare your map for digitising

A printed map for digitising should be reliable, up-to-date, flat and not torn or folded. 
Remember that paper is very flexible and changes its shape with moisture content. 

Before starting digitising you must identify a co-ordinate system for your map. If you are not 
going to combine your digitised data with any other data you can choose an arbitrary (local) 
co-ordinate system. However, in this exercise we shall digitise a bedrock map over part of 
Örebro county in the official Swedish co-ordinate system – rikets nät. Look at your printed 
map to identify co-ordinates of rikets nät. Rikets nät has meters or kilometers (km) as 
distance units – on your paper map it is given in km. Also have a look at the back side of the 
map – there you find information on its content, as well as projection and scale. 



Place your map on the digitising tablet and, if necessary attach it with masking tape. The 
Wacom tablet has plastic folder with which you can fix the map.

Prepare ArcView for digitising

Before starting the computer make sure the digitising table is connected and switched on. If 
you started the computer without the digitising table on, you have to reboot the computer and 
start the digitising table before the computer.

You will digitise in ArcView, thus start 
ArcView.  To be able to digitise in ArcView 
you must first add an extension. In the 
project menu choose File and Extensions. In
the extensions menu click the check box for 
Digitizer. Click OK.

Create a new empty view. For the exercise we will use a digital 
version of the same bedrock map as backdrop – to compare the 
quality and generalisations used for generating the printed map 

and the digital map. Thus use the add button, , to add the 
theme berg_10f, which you find under z:/_shared files/
geoinformatik/data/arbetsstuga2000/arcview/sgu/berg.
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Classify the bedrock theme into unique values. If you want to decode the classification have a
look at the html file Z:\_Shared files\Geoinformatik\data\Arbetsstuga2000\html\kodberg.htm.

Prepare the view for digitising

Before digitising you must specify 
the View Properties specifically 
Map Units and Distance Units. 
Set both Map and Distance Units 
to meters. Do not bother about 
Projection or Area Of Interest.

Registering your map

To digitise features you need to register your printed map to the geographic space in your 
view. This is done by digitising control points in your map for which you know the ground 
co-ordinates.
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From the View menu, choose Digitizer Setup (as to the right – if 
you do not have this option in the View menu it is because you 
did not add the Digitizer extension). You should now be presented
with the Digitizer Setup menu.

Start by changing the Error Limit to somewhere between 0.1 and 
0.01. Then press the Digitising Puck (see the figure above).

You must digitise and fill in the co-ordinates 
of at least four control points. Remember that 
the co-ordinates given for rikets nät are in km 
on your map – but that you must give meter as
input unit to register your map to the digital 
map (as to the right). Once you have digitised 
a control point ArcView enters an asterisk. 
When you have given four control points the 
Calculated Error will be presented. This 
error must be less than the Error Limit, or else
you will not be able to Register. 
If your Calculated Error is larger then the Error Limit you have three options:
- select the record with the largest error by clicking in it and digitise it again,
- add more control points, or
- increase the Error Limit to be larger than the Calculated Error.

Once you have entered the control points and are satisfied you can Save them. The next time
you want to register this map you can Load this “tic” file instead of entering the co-ordinates.
As digitising is rather sensitive, and one of the weakest parts of the ArcView program, it is 
recommended that you save the control points. Most likely your digitising session will cause 
errors now and then. 

Click the Register button to register your printed map to the view. If you did everything 
correct the ordinary mouse is not working – just try to move it do not click with it!
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Digitise the bedrock map

Before starting digitising you must check that your printed map matches the digital map that 
you have already loaded, and check the function of the digitising mouse. 

Digitising tables operate in two modes, absolute (digitising) mode and relative (mouse) 
modes. If you followed the instructions you should be in absolute mode. If you are in 
absolute mode the ordinary mouse is not working, whereas the digitising mouse is. You will 
also see the correct co-ordinates of the digitising mouse in its registered system in the lower 

left corner of the ArcView window, . Drag the digitising mouse
to a corner of your map and see if it fits with the bedrock map that you have in your view 
already. If you do not see the movements of the digitising mouse on top of the added bedrock 
map you have made some mistake in setting map units, or in registering your printed map. 
Thus you must start again.

To toggle between absolute (digitising) mode and relative modes press the F2 button. Thus if 
your ordinary mouse works you are in relative mode, press F2 to toggle to absolute mode. 

Change to relative mode by pressing F2. The ordinary mouse functions as usual, and also the 
digitising mouse functions as an ordinary mouse. You have lost the reference between your 
digital map and the registered map on the digitising table. The digitising mouse has a special 
set of buttons compared to the ordinary mouse.
You can not double click on 
the digitising mouse – instead 
the two buttons behind the 
ordinary left and right buttons 
have the function of double 
clicking. Remember this.

When you are in relative mode it is suggested that you use the Zoom in tool to make your 
view correspond better with your printed map.

Make sure you are in relative mode (the ordinary mouse is working). From the View menu 
choose New Theme, and select Point as the Feature type. 
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Make sure that the new theme is the only active theme. Specify a 
name for the point feature under Theme and Properties in the menu.

In the Theme Properties menu 
change the name to mine or 
church or any other point feature 
that you want to digitise. Click 
OK.

You will now have an empty theme in your view. Note the dashed line around the check box.
It indicates that you are in edit mode and that points can be added. 

Click on the “Draw point” tool .
Change to absolute (digitise) mode. Use the digitising mouse to locate mines (or churches) 
and press the left mouse button to register the points. It is enough if you digitise five to six 
points. Toggle to relative mode – if this does not work click the left mouse button on the 
ordinary mouse once, and then toggle by pressing F2.

Look at the attribute data connected to the newly created theme. Either you can open the 
theme table by going back to the Project window, select Table as document and Add table. 

Or you can press the “Open theme table” button  while having the theme active. Note that
menu bar, buttons and tools where changed when you went from the view document to the 
table document.
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1. Under the View menu choose New theme

2. Select Point as Feature type 3. Press OK

This is the Draw point tool



As you can see the table contains no attributes, only a field defining the shape type (point) 
and a field with zero values. Try to press one of the records (a line is record and a column is a
field), the selected record should now turn yellow and the corresponding point in the view is 
indicated by handles or turns yellow dependent on the version and setting of ArcView. Also 
try the buttons for “Select All”, “Select None” and “Switch” selection

.

Now we shall add a field and enter data to 
our point theme. You are probably in edit 
mode – if you have normal type face in the
table you are. Start Editing under Table in
the menu bar (if the drop down menu says 
Stop edit/Save edit etc – you are already 
in edit mode). Under Edit in the menu bar 
select Add Field; and one field defining 
the mines/churches with the following 
definitions:
Definition Field 

Name Mine
Type String
Width 20

Before you can enter data you have to click the Edit tool . The Edit tool might be difficult

to see, but it is between the Pointer tool and the Information tool . When you 
have activated the Edit tool you can type in data in your records. To know what position you 
are typing for you have to have the view displayed in the background to see which of your 
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Start editing and Stop Editing from the Table 
menu

Note that Table is the active document

Add Field under the Edit menu

1. Start Editing under the Table menu

2. Add field under the Edit menu

3. Fill in the definitions



digitised points gets handles (turns yellow) dependent on what record you are typing in. To 
change feature you must toggle to the Pointer tool. Type the kind of object that you digitised 
(e.g. sulfide ore mine / church) When you have finished choose Stop Editing from the Table 
menu and save the changes. Note how the type face in the field headings of the table turns 
from normal to italics when you stop editing, i.e. edit mode is indicated by a normal type 
face.

Return to the view containing your theme. Note that there is no dashed line around the check 
box - the dashed line also indicates edit mode, albeit in the view.

Now we shall have a look at how to change
colour and style of a theme displayed in the
view. That is done with the help of the 
legend editor. To open the legend editor 
either double click on the legend of the 
theme, or activate the theme (click once on 
the text in the legend and the whole box 
gets a raised appearance) and click

Edit legend          under Theme in 
the menu bar. Start by changing colour of 
the points, just double click on the coloured
point under symbol.
In the same menu that appears you can also
change type and style of the symbol. To 
activate the changes you must always press 
Apply in the Legend editor! 
In the legend editor you can also classify 
your data and create colours or symbols 
representing unique values (for qualitative 
data) or graduated colours (for quantitative

data). 

Move and delete points in the existing 
point theme by Start editing from the 
Theme menu - as a result the dashed line 
should appear around the check box and 
the text in the theme table becomes 

normal. Use the pointer tool to select a point to 
move or delete. If you want to delete a point 
simply press the DELETE key on the keyboard, 
to move it drag it to a new position with the 
mouse. Once finished Stop editing from the 
Theme menu and save the changes

Digitise tectonic zones and faults

Create another New Theme from the View menu to add a line theme. Make sure the new 

theme is the only active theme. In the tool menu you should have a line drawing tool  
where you previously had the tool for drawing a point. Click on the Line drawing tool. 
Toggle to absolute digitising mode and trace the tectonic lines and fault lines that you can 
find in your map. Default digitising mode is point mode, that means that you must click the 
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1. Double click the point symbol

2. Double click the brush

3. Change the size range 4-124. Apply

3. Double click a   
color

4. click Apply to 
activate



left mouse button for every vertex (breaking point) when you trace the line feature. To finish 
a line you should press the digitising mouse “left double click” button (behind the normal left
button) – do not double click the upper left button as this will just enter more line vertices.

When you have digitised all tectonic zones and faults toggle to relative mode by pressing F2 
(again you might need to press the ordinary mouse before this is possible). Open the theme 
table, add a string field where you also enter either “fault” or “tectonic zone”. Save the edits 
in your line field, stop editing, rename the theme to “faults”.

Digitise bedrock areas

Once again create a New theme, but this time choose Feature type to be Polygon. The 
default drawing tool should become a rectangle, and if you click and hold down the left 
mouse button on the Rectangle drawing tool you should see the drop down menu as this:

The Rectangle drawing tool is default when your theme is a polygon
The point drawing tool is shaded and can not be activated,
and the same holds for the line drawing tools

The rectangle itself is a possible choice.
With the circle you can draw a perfect polygon circle.
And with the Polygon tool it is possible to draw any polygon.
The ”Draw line to split feature” is inaccessible.
The Polygon split tool allows you to draw a line across a polygon to split it.
The AutoCompute tool is used to create a new polygon if it shares part of its boundary 
with existing polygons.

As we want to digitise irregular polygons start by selecting the Polygon tool. Digitise one of 
the homogenous areas on your map, trace by using the left mouse button and click to register 
all vertices in the polygon, finish by using the “left double click” button.
If you want to digitise an area adjacent to one that you have 
already entered you must change to the AutoCompute tool (see 
above). To do that you must first toggle to relative mode. Be sure 
to start tracing inside the existing polygon, trace the adjacent 
feature and finish (by the “left double click” button) when again 
inside the existing the polygon. You can also digitise an island 
polygon (a polygon wholly enclosed by another polygon) and 
afterward delete the original polygon under the “island” – the 
original polygon is then called a donut polygon. Trace an island 
polygon in an existing polygon. Toggle to relative mode. Choose 
the Pointer tool and select first the island polygon by pointing at it
and clicking the mouse. Hold down the ctrl and shift keys and 
highlight the surrounding polygon. Under Edit in the menu choose 
Subtract 
Feature – that turns the surrounding polygon into a donut. As you can see under the Edit 
menu there are also other options for manipulating existing polygons.
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Try to digitise several areas, and also try to create island and donut polygons. Digitising is 
rather tiresome and tricky – but at least you know that now! To complete the exercise you 
must create a layout of your digitising and hand in a map having points, lines and polygons, 
you can either hand it in digital format or as a paper map. Under File in the layout menu you 
have the option Export where you can create a digital output of your layout.  Do not forget to
put your name(s) on the map you hand in.

To complete the exercise within 4 hours do 
not put any energy into creating a detailed 
map – a generalised version like the one to 
the right is fine. 
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